Sugerencia de actualización de Internet Explorer 7 o anteriores.

Sugerencia de actualización de Internet Explorer 7 o anteriores.

Sabemos bien que Internet Explorer no soporta los estándares web comunes, ya que éste no cumple con reglas básicas estándar, sino que tiene sus propias reglas y por ende, cuando diseñamos u obtenemos plantillas de otros sitios nos llevamos la sorpresa de que no se previsualizan bien en este navegador.


Lo que haremos en esta oportunidad será mostrar un mensaje que sólo se visualice en Internet Explorer 7 y anteriores, y que a su vez deshabilite el contenido de nuestro blog al intentar acceder desde uno de estos antiguos navegadores.

Vista previa del resultado (Clic para aumentar):



¿Cómo añadirlo en Blogger?

Primero, vamos a ''Diseño | Edición HTML'' en donde marcamos ''Expandir plantillas de artilugios''.

Buscamos la siguiente sección:
<div id='content-wrapper'>

Arriba de ésta, pega el siguiente código:

<!--[if IE 7]>
<div id="internetexplorer">

Estás utilizando un navegador obsoleto, por lo que no es posible visualizar este blog, te recomendamos descargar la versión más reciente de Internet Explorer.

<p><b>Nota:</b> Este Blog trabaja mejor con Firefox 4 y posteriores.</p>

&#191;Qué deseas hacer?
<li><a href="http://www.mozilla-europe.org/es/" target="_blank">Descargar Firefox</a></li>
<li><a href="http://windows.microsoft.com/es-ES/internet-explorer/products/ie/home" target="_blank">Actualizar Internet Explorer</a></li>
<li><a href="http://www.google.com/chrome/?hl=es" target="_blank">Descargar Google Chrome</a></li>


</div>

<style type="text/css">
#content-wrapper {
visibility:hidden;
display:none;
}

#internetexplorer {
width:920px;
margin:0px auto;
font-size:18px;
padding: 15px;
border:3px solid #fff;
}

#internetexplorer li {
margin-top:10px;
margin-left:20px;
padding-bottom:4px;
}

#footer-wrapper {
visibility:hidden;
display:none;
}

</style>
<![endif]-->

Guardas los cambios y listo.


Consideraciones:

Para definir a qué versión de Internet Explorer quieres que aparezca, sólo cambia el número de la versión en <!--[if IE 7]>, por ejemplo:

Para Internet Explorer 6
<!--[if IE 6]>
Para Internet Explorer 8
<!--[if IE 8]>
Artículo aleatorio
BuySellAds
BuySellAds
BuySellAds
BuySellAds
BuySellAds
Artículos destacados
Botones para subir y bajar en Blogger # - Botones para subir y bajar en Blogger
Marca de agua en las imágenes con CSS # - Marca de agua en las imágenes con CSS
Efecto de desenfoque con CSS # - Efecto de desenfoque con CSS
Vídeotutorial: Crear plantilla para Blogger: Introducción a los códigos esenciales de Blogger # - Vídeotutorial: Crear plantilla para Blogger: Introducción a los códigos esenciales de Blogger
Insertar una página externa en una entrada en Blogger # - Insertar una página externa en una entrada en Blogger